My client takes hot backups of DOORS. I know this is bad and I'm going to change it, but for now that's what I have to work with. |
Re: Restore DOORS DB to a new server from a hot backup Not sure your problem. Perhaps you are failing to turn off the 2nd server before wiping out its database file hierarchy and replacing it with the production database, then starting the 2nd server. -Louie |
Re: Restore DOORS DB to a new server from a hot backup The servdata.lck (already mentioned) and the servdata.dtc file. Then try restarting the service. These files can be found at the root of your data folder. (eg c:\DOORSHOME%\data) Question....are the database files local to the server or your machine or are they on a NAS system? If they are on a NAS system it is most likely another reason you cannot start the service. |
Re: Restore DOORS DB to a new server from a hot backup SystemAdmin - Wed Jun 10 07:04:33 EDT 2009 Thank you so much! That was it. Deleting just the servdata.lck doesn't work. If you delete both it does. However, I also deleted some addition files (I believe server_settings) and that caused me not to be able to start DOORS. I appreciate the tip--I was really thinking tihs was some sort of backup configuration error. |
Re: Restore DOORS DB to a new server from a hot backup DOORS does not (at time of writing, so for versions of DOORS up to & including 9.2) support hot backups - in this case, it looks like the backup was taken without clients connected and no issues of any consequence resulted. However, if clients are connected and saving changes as the backup utility gallops through the database, parts of the data may be backed up in a transient and/or inconsistent state. Tidying up after restoring such a backup is restored is a skilled, and potentially very time-consuming exercise. |